기본 콘텐츠로 건너뛰기

Zend Framework 2.5 릴리즈



지난 4월달에 Zend Framework 2.4가 릴리즈되었다라는 포스팅을 하였는데 오늘 2.5 버전이 릴리즈되었습니다. 두 버전 사이의 릴리즈 기간만 보면 너무 빠르다고 생각할 수 있지만 Zend Framework 2.4는 LTS(Long Term Support) 버전이고 2.5 버전은 Zend Framework 3를 준비하기 위한 중간 단계 버전이라는 차이가 있습니다. 우분투가 2년마다 LTS 버전을 발표하면서 그 중간 6개월마다 일반 버전을 발표하는 것과 같은 정책이라고 볼 수 있습니다.

Zend Framework 2.5의 소스는 2.4 버전과 거의 같다고 합니다. 2.5가 가지고 있는 큰 변화점은 이제 Zend Framework 설치 및 업데이트는 무조건 composer를 사용하여야 한다라는 것입니다. 2.5 버전의 발표문과 Zend Framework 웹사이트 내의 다운로드 페이지에도 2.5 버전의 다운로드 링크를 제공하지 않고 있습니다. 제가 처음 Zend Framework 2를 사용하기 시작하였을 때 의문스러웠던 것 중 하나가 설치하는 방법이 여러가지라는 것이었는데 이번 릴리즈를 통해 composer 사용으로 통일이 되었습니다.

또다른 변화점은 Zend Framework 사용을 위한 최소 PHP 버전이 5.5가 되었다라는 것입니다. Zend Framework 2.4에서는 5.3.23이 최소 버전이었는데 두 단계가 올랐습니다. PHP 5.3 버전은 더이상 업데이트 지원이 없고 5.4 버전도 올해 종료될 예정이기 때문이라고 하는데 이 역시 Zend Framework 3를 위한 버전업이라고 생각할 수 있을 것 같습니다.

처음부분에 이야기한 것처럼 이번 2.5 버전은 Zend Framework 3를 위한 첫번째 중간 단계 버전입니다. Zend Framework로 웹서비스를 하고 있는 경우라면 Zend Framework 3가 발표되기 전까지는 LTS 버전인 2.4에서 머물러 있는 것이 좋을 것 같습니다.


===


사진 포트폴리오 - City, City People (http://photo.just4fun.kr/)

사진 매거진 앱 - Viewzin (http://viewzin.just4fun.kr/)



댓글

이 블로그의 인기 게시물

크롬북에서 리눅스 앱 사용 후기

새로 구입한 픽셀 슬레이트에서 리눅스 앱을 실행시켜본 후 작성한 후기입니다. 현재 크롬북에서 리눅스 앱을 실행시키는 기능은 베타이니 이점을 고려하시고 보시면 좋을 것 같습니다.

Google Pixel Slate : 혼돈의 카오스

기존에 사용하던 픽셀 C의 교체 기기로 구입한 Pixel Slate(픽셀 슬레이트)는 제가 개인적으로 구입한 IT 기기 중 가격을 고려한다면 가장 실망한 기기입니다. 지적할 문제가 너무 많아 어디서부터 이야기해야 하나 고민을 하다가 가장 큰 문제라고 생각한 OS의 '일관성'에 대한 부분만 이야기하고 다른 것들에 대해서는 글 마지막 부분에 간단 리스트로 정리하기로 하였습니다.

구글 결제에서 결제 수단 등록 문제

얼마 전 카드를 새로 만들어서 구글 결제의 결제 수단을 교체하려고 하였는데 카드 번호가 잘못되었다라고 하면서 등록이 되지 않았습니다. 관련해서 검색을 해보니 이런 문제가 흔히 발생하고 있더군요. 저처럼 당황하실 분들을 위해 구글 고객센터와 통화해 해결하면서 알아낸 것들을 공유하겠습니다.